Updated Multi Session Mapping with RTAB Map Tango (markdown)

matlabbe
2017-03-31 20:52:50 -04:00
parent d6fd7f1e84
commit 0d9c29af38
+3
@@ -1,6 +1,8 @@
## Introduction ## Introduction
This tutorial shows how to merge multiple RTAB-Map databases taken with [RTAB-Map Tango](https://play.google.com/store/apps/details?id=com.introlab.rtabmap). The same approach would apply with databases taken with RTAB-Map Desktop and `rtabmap_ros`. To see a multi-session example from data captured on a robot, see the original [Multi-Session tutorial](https://github.com/introlab/rtabmap/wiki/Multi-session). This tutorial shows how to merge multiple RTAB-Map databases taken with [RTAB-Map Tango](https://play.google.com/store/apps/details?id=com.introlab.rtabmap). The same approach would apply with databases taken with RTAB-Map Desktop and `rtabmap_ros`. To see a multi-session example from data captured on a robot, see the original [Multi-Session tutorial](https://github.com/introlab/rtabmap/wiki/Multi-session).
[[doc/Tutorials/MultiSessionTango/cloud.jpg]][[doc/Tutorials/MultiSessionTango/cloudSessionColor.jpg]]
## Steps ## Steps
### 1. Scanning tips ### 1. Scanning tips
@@ -53,6 +55,7 @@ To optimize the map even more, click on Tools->Post-processing, check Detect mor
### 7. Export the mesh. ### 7. Export the mesh.
Click "File->Export 3D clouds..." and setup the panel as the following screenshot and click "Save". If you prefer exporting the point cloud and create the mesh (and texturing) with another software, you can see the [Export Rasters Layer to MeshLab](https://github.com/introlab/rtabmap/wiki/Export-Raster-Layers-to-MeshLab) tutorial. Wait a couple of minutes then you will be able to save the OBJ. Click "File->Export 3D clouds..." and setup the panel as the following screenshot and click "Save". If you prefer exporting the point cloud and create the mesh (and texturing) with another software, you can see the [Export Rasters Layer to MeshLab](https://github.com/introlab/rtabmap/wiki/Export-Raster-Layers-to-MeshLab) tutorial. Wait a couple of minutes then you will be able to save the OBJ.
[[doc/Tutorials/MultiSessionTango/export.jpg]] [[doc/Tutorials/MultiSessionTango/export.jpg]]
[[doc/Tutorials/MultiSessionTango/mesh.jpg]]
## Other examples with Tango ## Other examples with Tango
The following examples are single session mapping, but have very similar workflow than shown in this tutorial to re-process the database. In these cases, the databases have been re-processed with different parameters to get more loop closures than with the default parameters. The following examples are single session mapping, but have very similar workflow than shown in this tutorial to re-process the database. In these cases, the databases have been re-processed with different parameters to get more loop closures than with the default parameters.