From af9c518fead57df6c0628e2c8ed4aef032908981 Mon Sep 17 00:00:00 2001 From: matlabbe Date: Wed, 4 Jan 2017 14:25:23 -0500 Subject: [PATCH] Updated Export Raster Layers to MeshLab (markdown) --- Export-Raster-Layers-to-MeshLab.md | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/Export-Raster-Layers-to-MeshLab.md b/Export-Raster-Layers-to-MeshLab.md index 9db42d5..b4b5bab 100644 --- a/Export-Raster-Layers-to-MeshLab.md +++ b/Export-Raster-Layers-to-MeshLab.md @@ -11,7 +11,7 @@ The goal of this tutorial is to export a low resolution mesh and cameras to [Mes 3. Open the download database `2loops_workspace_3IT.db` 4. Click on "Download all clouds (update cache)". Click `OK` for "Global map optimized". In the 3D Map view, you should see the point cloud like this: ![Point cloud without SBA](https://raw.githubusercontent.com/wiki/introlab/rtabmap/doc/Tutorials/Texture/without_sba.png) -5. **Optional** We will do a post-processing of the map to make it more straight. To do that, click on Tools->"Post-processing...". Set the parameters as below and click `OK` (select `cvsba` instead of `g2o` in latest versions). Sparse Bundle Adjustment (SBA) will optimize the map with the camera positions and the matching visual features between the cameras. You will then get the point cloud as the third image. In some cases, the results may be worst with SBA, to revert post-processing, just click on Edit->"Download graph only" (with global optimized option). Detecting more loop closures give generally good results. If the environment has a lot of geometry, you can refine the links with ICP. +5. **Optional** We will do a post-processing of the map to make it more straight. To do that, click on Tools->"Post-processing...". Set the parameters as below and click `OK`. Sparse Bundle Adjustment (SBA) will optimize the map with the camera positions and the matching visual features between the cameras. You will then get the point cloud as the third image. In some cases, the results may be worst with SBA, to revert post-processing, just click on Edit->"Download graph only" (with global optimized option). Detecting more loop closures give generally good results. If the environment has a lot of geometry, you can refine the links with ICP. ![Post-processing dialog](https://raw.githubusercontent.com/wiki/introlab/rtabmap/doc/Tutorials/Texture/sba_dialog.jpeg) ![Post-processing progress](https://raw.githubusercontent.com/wiki/introlab/rtabmap/doc/Tutorials/Texture/sba_progress.jpeg) ![Point cloud with SBA](https://raw.githubusercontent.com/wiki/introlab/rtabmap/doc/Tutorials/Texture/with_sba.png)