From 24b23188e69ef74fea21434bbabdfe6793456b31 Mon Sep 17 00:00:00 2001 From: matlabbe Date: Sun, 23 Nov 2014 16:36:39 -0800 Subject: [PATCH] Updated Loop closure detection (markdown) --- Loop-closure-detection.md | 27 ++++++++++++++------------- 1 file changed, 14 insertions(+), 13 deletions(-) diff --git a/Loop-closure-detection.md b/Loop-closure-detection.md index 485c0a3..d8eb244 100644 --- a/Loop-closure-detection.md +++ b/Loop-closure-detection.md @@ -6,18 +6,19 @@ This simple example shows how to use RTAB-Map to process a data set. * Open RTAB-Map application. At the first execution, you should see a dialog saying that a working directory is created in your "Documents" folder, click ok. This working directory holds the database and log files. - ![](https://raw.githubusercontent.com/introlab/rtabmap/doc/Tutorials/ProcessADataSet/dialog_working_directory.png) + [[doc/Tutorials/ProcessADataSet/dialog_working_directory.png]] + * At this point, you should see the main window of RTAB-Map. - ![](https://raw.githubusercontent.com/introlab/rtabmap/doc/Tutorials/ProcessADataSet/main_window.png) + [[doc/Tutorials/ProcessADataSet/main_window.png]] * Clean the working directory. Menu Edit -> "Delete memory (# Mb)". A warning is shown about erasing the database. If you don't need to keep it, click ok. Otherwise, click no, then Menu Edit -> "Show working directory in file browser" and backup the database (LTM.db) and log files (LogI.txt, LogF.txt) before executing the "Delete memory" action. - ![](https://raw.githubusercontent.com/introlab/rtabmap/doc/Tutorials/ProcessADataSet/menu_delete_memory.png) + [[doc/Tutorials/ProcessADataSet/menu_delete_memory.png]] - ![](https://raw.githubusercontent.com/introlab/rtabmap/doc/Tutorials/ProcessADataSet/dialog_delete_mem.png) + [[doc/Tutorials/ProcessADataSet/dialog_delete_mem.png]] - * Setup parameters for appearance-based mapping only. Download this file [settingsAppearanceDemo.ini](https://raw.githubusercontent.com/introlab/rtabmap/doc/Tutorials/ProcessADataSet/settingsAppearanceDemo.ini), open Edit->Preferences->General settings, click on "Load settings" and select the file you have just downloaded. Here information about which parameters are modified from the default ones: + * Setup parameters for appearance-based mapping only. Download this file [settingsAppearanceDemo.ini](https://raw.githubusercontent.com/wiki/introlab/rtabmap/doc/Tutorials/ProcessADataSet/settingsAppearanceDemo.ini), open Edit->Preferences->General settings, click on "Load settings" and select the file you have just downloaded. Here information about which parameters are modified from the default ones: * RGBD/Enabled = False (disable metric stuff) * Rtabmap/ImageBufferSize = 0 (process all images) * Rtabmap/DetectionRate = 0 (go as fast as the camera publishes images) @@ -27,19 +28,19 @@ This simple example shows how to use RTAB-Map to process a data set. * Mem/BadSignaturesIgnored = true (ignore images with little or no features) * Setup the source of the camera. For this example, download this [sample data set](https://raw.githubusercontent.com/introlab/rtabmap/master/bin/data/samples.zip) and extract it anywhere. Menu Detection -> "Select Source" -> "Images ...". Select the directory containing images just extracted. - ![](https://raw.githubusercontent.com/introlab/rtabmap/doc/Tutorials/ProcessADataSet/menu_source_images.png) + [[doc/Tutorials/ProcessADataSet/menu_source_images.png]] * Click on "Start" button in the toolbox of the main window. You should see briefly an initialization dialog and the detection is paused on the first image. The initialization can be done before starting (Menu Edit -> "Apply settings to the detector"), thus the detection will not be paused when starting the detection. - ![](https://raw.githubusercontent.com/introlab/rtabmap/doc/Tutorials/ProcessADataSet/dialog_initialization.png) + [[doc/Tutorials/ProcessADataSet/dialog_initialization.png]] - ![](https://raw.githubusercontent.com/introlab/rtabmap/doc/Tutorials/ProcessADataSet/main_detection_start.png) + [[doc/Tutorials/ProcessADataSet/main_detection_start.png]] * Push button "Pause on match". This will make the detector pause when an accepted loop closure is found. * Push button "Pause" to continue the detection. The detection should work until the image 50 is acquired. - ![](https://raw.githubusercontent.com/introlab/rtabmap/doc/Tutorials/ProcessADataSet/main_loop_detected.png) + [[doc/Tutorials/ProcessADataSet/main_loop_detected.png]] * Colors legend : * Blue = feature found in the previous image (when almost all features are blue, this means that the current image is merged with the previous one, increasing the weight). @@ -54,18 +55,18 @@ This simple example shows how to use RTAB-Map to process a data set. * When the last image (84) is processed, click Menu Window -> "Show view" -> Statistics. This will open a panel showing statistics. For this tutorial, look only information in the top part of the panel. We can see the number of loop closures detected/rejected. - ![](https://raw.githubusercontent.com/introlab/rtabmap/doc/Tutorials/ProcessADataSet/main_statistics.png) + [[doc/Tutorials/ProcessADataSet/main_statistics.png]] ## Other data sets * You can try with larger data sets that you can find at [RTAB-Map on IntRoLab](https://introlab.3it.usherbrooke.ca/mediawiki-introlab/index.php/RTAB-Map): * UdeS data set: - [![video](https://raw.githubusercontent.com/introlab/rtabmap/doc/video_screenshots/udes.jpeg)](http://www.youtube.com/watch?v=0zWs6jTaAwQ) + [![[doc/video_screenshots/udes.jpeg]]](http://www.youtube.com/watch?v=0zWs6jTaAwQ) * NFSMW data set - [![video](https://raw.githubusercontent.com/introlab/rtabmap/doc/video_screenshots/nfsmw1.jpeg)](http://www.youtube.com/watch?v=kghs6XM8Yzw) + [![[doc/video_screenshots/nfsmw1.jpeg]]](http://www.youtube.com/watch?v=kghs6XM8Yzw) - [![video](https://raw.githubusercontent.com/introlab/rtabmap/doc/video_screenshots/nfsmw2.jpeg)](http://www.youtube.com/watch?v=awV2Xbjq7OM) + [![[doc/video_screenshots/nfsmw2.jpeg]]](http://www.youtube.com/watch?v=awV2Xbjq7OM) \ No newline at end of file